Thema Datum  Von Nutzer Rating
Antwort
Rot Makro für Formel weiter kopieren in Spalte
30.03.2023 08:01:12 Tom
Solved
30.03.2023 08:25:21 UweD
Solved
30.03.2023 10:37:02 Tom
Solved

Ansicht des Beitrags:
Von:
Tom
Datum:
30.03.2023 08:01:12
Views:
803
Rating: Antwort:
 Nein
Thema:
Makro für Formel weiter kopieren in Spalte

Hallo zusammen,

Habe folgendes Problem:

Möchte gerne das in Excel ein Makro mir die Formel die in Zelle B1 steht die ganze Spalte B weiter kopiert solange es einen Zelleninhalt in Spalte A gibt

optimal wäre es sogar das ab Zelle B2 bis ende nur des Ergebnis eingefügt wird also nicht die Formel damit das Programm sich nicht aufhängt

die Formel in Zelle B1 sieht so aus =>

=WENNFEHLER(WENN(WENNFEHLER((RUNDEN(TEIL($A1;FINDEN("X";$A1)+1;FINDEN(" ";$A1;FINDEN("X";$A1))-FINDEN("X";$A1))/5;1)*5);"")+WENNFEHLER((RUNDEN(TEIL($A1;FINDEN("Y";$A1)+1;FINDEN(" ";$A1;FINDEN("Y";$A1))-FINDEN("Y";$A1))/5;1)*5);"")>0;WENNFEHLER((RUNDEN(TEIL($A1;FINDEN("X";$A1)+1;FINDEN(" ";$A1;FINDEN("X";$A1))-FINDEN("X";$A1))/5;1)*5);"")&","&WENNFEHLER((RUNDEN(TEIL($A1;FINDEN("Y";$A1)+1;FINDEN(" ";$A1;FINDEN("Y";$A1))-FINDEN("Y";$A1))/5;1)*5);"")&","&WENNFEHLER(RUNDEN(TEIL($A1;FINDEN("Z";$A1)+1;10);2);"XXX");"");"Z")

 

vl hat von euch wer eine Lösung :)

Danke schonmal lg Tom


Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
Thema: Name: Email:

 
 

  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen

Thema Datum  Von Nutzer Rating
Antwort
Rot Makro für Formel weiter kopieren in Spalte
30.03.2023 08:01:12 Tom
Solved
30.03.2023 08:25:21 UweD
Solved
30.03.2023 10:37:02 Tom
Solved