Thema Datum  Von Nutzer Rating
Antwort
Rot Bitte um Erklärung
07.01.2022 17:35:55 k
NotSolved
07.01.2022 18:38:04 ralf_b
NotSolved

Ansicht des Beitrags:
Von:
k
Datum:
07.01.2022 17:35:55
Views:
76
Rating: Antwort:
  Ja
Thema:
Bitte um Erklärung

Hallo Leute, ich hab hier ein kleines Problem...Kann mir hier einer erklären welche Funktionen dieser Code mit sich bringt? 

 

 

Sub Worksheet_Selectionchange(ByVal Target As Range)                                                        'Mit jedem Zellwert wird der Code ausgeführt

LetzteZeile = ActiveSheet.Cells(Rows.Count, 4).End(xlUp).Row                                                'Bestimmt letze befüllte Zeile von Spalte D im der Kontaktliste
If Not Intersect(Target, Range("D7:K" & LetzteZeile)) Is Nothing Then                                       'Hervorhebung der aktiven Zeile
If Target.CountLarge > 1 Then GoTo Mehrfachwahl
    Range("B4") = Target.Row
    Range("B5") = Cells(Target.Row, 4).Value
    Range("B6").FormulaLocal = "=WENNFEHLER(VERGLEICH(B$5;INDIREKT(""'""&$B3&""'!$B$1:$B$999999"");0);0)"
    Else:
    Range("B4") = 0
    Range("B5") = 0
Mehrfachwahl:
Range("B4") = 0
    End If
End Sub


Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
Thema: Name: Email:

 
 

  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen

Thema Datum  Von Nutzer Rating
Antwort
Rot Bitte um Erklärung
07.01.2022 17:35:55 k
NotSolved
07.01.2022 18:38:04 ralf_b
NotSolved