Thema Datum  Von Nutzer Rating
Antwort
Rot Warum Laufzeitfehler 1004 anwendungsfehler
09.07.2021 13:56:01 Bernd
Solved
09.07.2021 14:37:41 Mase
NotSolved
09.07.2021 14:48:00 Bernd
NotSolved
09.07.2021 14:51:36 Mase
NotSolved
09.07.2021 14:43:05 Bernd
Solved
09.07.2021 14:49:50 Gast97163
NotSolved

Ansicht des Beitrags:
Von:
Bernd
Datum:
09.07.2021 13:56:01
Views:
62
Rating: Antwort:
 Nein
Thema:
Warum Laufzeitfehler 1004 anwendungsfehler

Ich habe eine Codezeile:

ActiveCell.FormulaR1C1 = "=WENN(ISTFEHLER(SVERWEIS(B2;'Alle Aktive EQ 5 RB Mitte.XLSX'!$A:$A;1;FALSCH));""inaktiv"";""aktiv"""

im Code:

Range("A2").Select
    Application.CutCopyMode = False
    ActiveCell.FormulaR1C1 = "=WENN(ISTFEHLER(SVERWEIS(B2;'Alle Aktive EQ 5 RB Mitte.XLSX'!$A:$A;1;FALSCH));""inaktiv"";""aktiv"""
    Selection.AutoFill Destination:=Range("A2:A" & loLetzte), Type:=xlFillDefault

Mit ActiveCell.FormulaR1C1 habe ich bereits öfter Formeln in eine Zelle geschrieben und dann heruntergezogen.

loLetzte wird im vorhergehenden Code definiert

Jetzt bekomme ich einen Fehlercode: laufzeitfehler 1004 anwendungs- oder objektdefinierter fehler

Ich habe keine Ahnung warum.

Der String der in die Zelle geschrieben werden soll, sollte von VBA nicht geprüft werden. 

Also, wo liegt der Fehler?

 


Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
Thema: Name: Email:

 
 

  • Bitte beschreiben Sie Ihr Problem möglichst ausführlich. (Wichtige Info z.B.: Office Version, Betriebssystem, Wo genau kommen Sie nicht weiter)
  • Bitte helfen Sie ebenfalls wenn Ihnen geholfen werden konnte und markieren Sie Ihre Anfrage als erledigt (Klick auf Häckchen)
  • Bei Crossposting, entsprechende Links auf andere Forenbeiträge beifügen / nachtragen
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen

Thema Datum  Von Nutzer Rating
Antwort
Rot Warum Laufzeitfehler 1004 anwendungsfehler
09.07.2021 13:56:01 Bernd
Solved
09.07.2021 14:37:41 Mase
NotSolved
09.07.2021 14:48:00 Bernd
NotSolved
09.07.2021 14:51:36 Mase
NotSolved
09.07.2021 14:43:05 Bernd
Solved
09.07.2021 14:49:50 Gast97163
NotSolved