Thema Datum  Von Nutzer Rating
Antwort
Rot Sumif Formeln addieren?
07.03.2019 13:53:39 Justus
NotSolved
07.03.2019 16:31:55 Ulrich
NotSolved

Ansicht des Beitrags:
Von:
Justus
Datum:
07.03.2019 13:53:39
Views:
24
Rating: Antwort:
  Ja
Thema:
Sumif Formeln addieren?

Hallo Leute, 

ich hab vor ein paar Tagen hier im Forum gesehen, dass man SummeWenn Formeln auch in VBA rechnen lassen kann. 

Range("B2").Formula = "=sumif(" & Bereich1.Address(External:=True) & ", " & Zeile.Address & " ," & Bereich2.Address(External:=True) & ")"

Ist es auch möglich diese Formeln zu addieren und dann in eine Zelle zu schreiben? 

Also wenn ich zB sowas habe  =SUMMEWENN('Tabelle2'!$A:$A;$C$1;'Tabelle2'!$B:$B)+SUMMEWENN('Tabelle2'!$A:$A;$D$1;'Tabelle2'!$B:$B) 

+SUMMEWENN('Tabelle2'!$A:$A;$E$1;'Tabelle2'!$B:$B)+SUMMEWENN('Tabelle2'!$A:$A;$F$1;'Tabelle2'!$B:$B) 

Lerne grade erst VBA, also sorry für die noob Frage :D

 


Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst genau und ausführlich
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
  • Bitte markieren Sie Ihre Anfrage als erledigt wenn Ihnen geholfen wurde
Thema: Name: Email:

 
 

Thema Datum  Von Nutzer Rating
Antwort
Rot Sumif Formeln addieren?
07.03.2019 13:53:39 Justus
NotSolved
07.03.2019 16:31:55 Ulrich
NotSolved